SG Crawlers Forum
Search
 
 

Display results as :
 


Rechercher Advanced Search

SGCrawlers - Crawl & Trail videos
SGCrawlers - Bash Tour Drift videos
Who is online?
In total there are 11 users online :: 1 Registered, 0 Hidden and 10 Guests :: 1 Bot

ket2175

[ View the whole list ]


Most users ever online was 57 on Fri Sep 23, 2016 5:58 am
Latest topics
» Black Bandit Jeep Cherokee
by CraftRC Sun Apr 22, 2018 12:51 pm

» [Rifle Range Trail] Rifle Range Road - 22 Apr 2018 0900hrs
by boolean21 Sat Apr 21, 2018 1:14 pm

» 4x4 Winter offroad
by CraftRC Wed Apr 18, 2018 1:10 pm

» [MODS] SQ11 Mini cam - wide angle lens mod
by boolean21 Mon Apr 16, 2018 3:09 pm

» Gelande Land Rover Defender
by CraftRC Sat Apr 14, 2018 10:54 am

» [Scale Trail] Woodgrove Ave - Sunday 25 Mar 2018 0900hrs
by boolean21 Sat Mar 24, 2018 2:36 pm

» Yellow Hilux TrailFinder crawling
by CraftRC Sat Mar 24, 2018 9:02 am

» Jeep cherokee XJ truck
by CraftRC Sat Mar 17, 2018 12:31 pm

» RC jeep cherokee XJ
by CraftRC Sat Mar 17, 2018 12:30 pm

» Custom Land Rover Truck
by CraftRC Sat Mar 17, 2018 12:27 pm

» [Scale Trail] Woodgrove Ave - Sunday 25 Feb 2018 0900hrs
by boolean21 Sat Feb 24, 2018 1:41 pm

» [Touring / onroad bash] 11 Feb 2018 0900hrs - Touring, onroad bash and more @ 60 Punggol East
by boolean21 Sat Feb 10, 2018 1:31 pm

» Land rover Stuck in snow
by CraftRC Tue Jan 30, 2018 12:52 pm

» Gaz-66 Military Scale RC Truck
by CraftRC Sun Jan 28, 2018 1:20 pm

» RC HG P402
by boolean21 Fri Jan 19, 2018 3:14 pm

» [Scale Trail & Offroad bash] Woodgrove Ave - Sunday 21 Jan 2018 0900hrs
by boolean21 Fri Jan 19, 2018 3:13 pm

» RC HG P402
by hasitha2175 Sun Jan 07, 2018 7:02 am

» [RC 4x4 Trails] Rifle Range Road - 07 Jan 20 18 0900hrs
by boolean21 Sat Jan 06, 2018 5:47 am

» [Offroad Trail] 31 Dec 17 0830hrs - SGCrawlers Offroad Trail at 276 Bangkit Road
by boolean21 Sat Dec 30, 2017 8:16 am

» [RC 4x4 Trails] Rifle Range Road - 03 Dec 2017 0900hrs
by boolean21 Sat Dec 02, 2017 4:05 am

April 2018
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
30      

Calendar Calendar

Affiliates
free forum

Free Domain Name
Google+

Help Needed on Hyper 10sc...

Go down

Help Needed on Hyper 10sc...

Post by lenzpro.sg on Tue Feb 12, 2013 12:23 pm

Hi, my 1 week old hyper 10sc juz stopped running after just abt 20 secs on the road! Already reset the ESC but to no vail. Any of the experts here can help me pls...
avatar
lenzpro.sg
Crawler

Posts : 14
Join date : 2013-02-09
Location : Pasir Ris

View user profile http://www.lenzprosg.wix.com/lenzprosg

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by oceanic on Tue Feb 12, 2013 12:36 pm

Errrrr.....
It can be the esc, motor, tx or rx.
Cant tell what the problem u have bro....
Just wait for experts to reply

_________________
avatar
oceanic
Moderator

Posts : 1212
Join date : 2012-03-21
Location : N1°24.229' E103°48.094

View user profile http://sgcrawlers.weebly.com

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by lenzpro.sg on Tue Feb 12, 2013 12:53 pm

oceanic wrote:Errrrr.....
It can be the esc, motor, tx or rx.
Cant tell what the problem u have bro....
Just wait for experts to reply

Hi Bro Oceanic, I am just a month into this hobby and I really have no idea wats the problem. Tried googling but cant find the answers. Tx and buggy battery changed but same problem also..Hope the experts here could really shed some lights...thnks in advance...
avatar
lenzpro.sg
Crawler

Posts : 14
Join date : 2013-02-09
Location : Pasir Ris

View user profile http://www.lenzprosg.wix.com/lenzprosg

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by boolean21 on Tue Feb 12, 2013 1:26 pm

Maybe you can bring it down during the next bashing meet for the bros to take a look and see if anyone can help.

_________________
My Blogs: MyHoncho Blog | Boolean21 RC Blog
Youtube: SGCrawlers RC Channel | BooleanRC Video Channel
Facebook: SGCrawlers FB Page  | Boolean21 FB Page
Instagram: http://instagram.com/SGCrawlers
Twitter: http://twitter.com/SGCrawlers
avatar
boolean21
Crawler

Posts : 5027
Join date : 2011-08-18
Location : Deep inside the Jungle

View user profile https://www.youtube.com/MyHonchoSG

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by Harakiri on Tue Feb 12, 2013 1:29 pm

Hi bro welcome to sgc. For your question abt the sct may i ask is the esc fan running, if yes when u throttle the red n green light on the esc working. Did u adust anything on your Tx?
avatar
Harakiri
Boss

Posts : 305
Join date : 2011-08-22
Location : Deep Muddy Jungle

View user profile

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by lenzpro.sg on Tue Feb 12, 2013 1:57 pm

Harakiri wrote:Hi bro welcome to sgc. For your question abt the sct may i ask is the esc fan running, if yes when u throttle the red n green light on the esc working. Did u adust anything on your Tx?

Hi Bro Harakiri, yes the esc fan is running. When i turn on it turns red then off and i throttle it turns green before shutting down completely although the esc fan still running. I can't even turn the steering. I already reset the esc but same thing happen again. It will shutdown completely after about 20 sec. I did not do anthing to the controller except changed to a fresh set of batteries. Could water sipped into the esc or receiver coz the buggy had some splashing time after the heavy downpour...
avatar
lenzpro.sg
Crawler

Posts : 14
Join date : 2013-02-09
Location : Pasir Ris

View user profile http://www.lenzprosg.wix.com/lenzprosg

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by Teck on Tue Feb 12, 2013 8:22 pm

Hi where did u buy it from? Since it only 1 week old y don't u just send it back n ask the shop to help u with
Wat battery u using?
Is the motor n esc very hot after run?
avatar
Teck
Crawler

Posts : 552
Join date : 2011-09-27

View user profile

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by Harakiri on Wed Feb 13, 2013 1:23 am

Did u run your truck on water
avatar
Harakiri
Boss

Posts : 305
Join date : 2011-08-22
Location : Deep Muddy Jungle

View user profile

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by lenzpro.sg on Wed Feb 13, 2013 1:52 am

Teck wrote:Hi where did u buy it from? Since it only 1 week old y don't u just send it back n ask the shop to help u with
Wat battery u using?
Is the motor n esc very hot after run?

Hi bro is not that i dont want to go back to winnie but dat Uncle really got some attitude in serving his customers. Such a grumpy person. Went there once coz unsure of how to reset the esc. Was given an attitude service by this uncle. By the way im using a brand new 4200 mha 45c lipo 2s battery.
avatar
lenzpro.sg
Crawler

Posts : 14
Join date : 2013-02-09
Location : Pasir Ris

View user profile http://www.lenzprosg.wix.com/lenzprosg

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by lenzpro.sg on Wed Feb 13, 2013 1:55 am

Harakiri wrote:Did u run your truck on water

Yes bro harakiri i did ran over a pool of water....not once but a couple of times Crying or Very sad
avatar
lenzpro.sg
Crawler

Posts : 14
Join date : 2013-02-09
Location : Pasir Ris

View user profile http://www.lenzprosg.wix.com/lenzprosg

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by Teck on Wed Feb 13, 2013 2:14 am

In that case change a new set of esc n try again cause if not wrong the esc is not waterproof
avatar
Teck
Crawler

Posts : 552
Join date : 2011-09-27

View user profile

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by lenzpro.sg on Wed Feb 13, 2013 2:52 am

Teck wrote:In that case change a new set of esc n try again cause if not wrong the esc is not waterproof

Oh i see, coz thought da esc is splash proof... Could it also be the receiver fault also coz i observed its wet too...
avatar
lenzpro.sg
Crawler

Posts : 14
Join date : 2013-02-09
Location : Pasir Ris

View user profile http://www.lenzprosg.wix.com/lenzprosg

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by babyboy on Wed Feb 13, 2013 3:17 am

lenzpro.sg wrote:
Teck wrote:In that case change a new set of esc n try again cause if not wrong the esc is not waterproof

Oh i see, coz thought da esc is splash proof... Could it also be the receiver fault also coz i observed its wet too...

Is your rx waterproof? Test rx using a servo and a seperate rx battery. If both channel is working than rx ok.
avatar
babyboy
Crawler

Posts : 720
Join date : 2011-09-28

View user profile

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by lenzpro.sg on Wed Feb 13, 2013 3:27 am

babyboy wrote:
lenzpro.sg wrote:
Teck wrote:In that case change a new set of esc n try again cause if not wrong the esc is not waterproof

Oh i see, coz thought da esc is splash proof... Could it also be the receiver fault also coz i observed its wet too...

Is your rx waterproof? Test rx using a servo and a seperate rx battery. If both channel is working than rx ok.

Will try it out once im home bro. Thnk u so much for all da feedback. U guys are really great. Will definately meet up wif u guys on da next meet up.
avatar
lenzpro.sg
Crawler

Posts : 14
Join date : 2013-02-09
Location : Pasir Ris

View user profile http://www.lenzprosg.wix.com/lenzprosg

Back to top Go down

Re: Help Needed on Hyper 10sc...

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum